( Прайс-лист на услуги )

Перестал работать Netbios в windows 10

Netbios это протокол используемый в ОС семейства Windows для обнаружения устройств в сетевом окружении. Он очень старый (разработал в 1983 году), и ему на смену приходят другие протоколы (например, WSD и LLMNR). Но существует ещё множество устройств которые поддерживают только Netbios.

И вот у нас есть Windows 10 x64, работает WSD, LLMNR, но почему то не работает Netbios.

Выполнив команду "ipconfig /all"

Мы наблюдаем, что у адаптера "Broadcom NetLink (TM) Gigabit Ethernet" в строке "NetBios через TCP/IP" написано "Отключен".

При это сама Служба работает, в настройках протокола Ipv4 Netbios включен .

А при выполнении команды "nbtstat -n"

нам выводится ошибка 

"NetBT не привязан ни к одному устройству"

чтобы это исправить, нужно создать .cmd файл с командами

REG DELETE HKLM\SYSTEM\CurrentControlSet\Services\lanmanserver\Linkage /f
REG DELETE HKLM\SYSTEM\CurrentControlSet\Services\lanmanworkstation\Linkage /f 
REG DELETE HKLM\SYSTEM\CurrentControlSet\Services\NetBIOS\Linkage /f
REG DELETE HKLM\SYSTEM\CurrentControlSet\Services\NetBT\Linkage /f
REG DELETE HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Linkage /f

После запуска файла нужно сделать сброс сети. Сделать это мтожно следующим образом:
"Пуск" - "параметры" - "Сеть и интернет" - "Сброс сети" (в самом низу).

После перезагрузки Netbios заработал.

"ipconfig /all" показывает

NetBios через TCP/IP. . . . . . . . : Включен

Результат работы команды "
nbtstat -n"
 

Рейтинг@Mail.ru Яндекс.Метрика